How can we improve?

Suppress "Backend Database Error" Warning when OS is rebooted

Suppress "Backend Database Error" Warning when OS is rebooted

We reboot the Mail Archiver server weekly and after installing Microsoft Updates, which can often result in an email warning being sent out with the subject "GFI Archiver: Backend Database Error" and the body:

"GFI Archiver failed to archive any emails into the backend database.

The following error message was reported:
The transaction has aborted.

Regards,
GFI Archiver

We do want to be notified in all other cases if there should be an issue, but rebooting is not one of them. A workaround is to disable all such warning messages (option found in Configuration > general settings > additional settings > send archiving status notification), but then we are not notified of other potential problems.

I did file case GFI-160525-412152 on this. It was suggested to me that I post this in the ideas area.

1 vote
Sign in
Signed in as (Sign out)

We’ll send you updates on this idea

Michael Handy shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

1 comment

Sign in
Signed in as (Sign out)
Submitting...
  • AdminIan Bugeja (Director, Product Management, GFI) commented  ·   ·  Flag as inappropriate

    Hi

    This happens if the archiver server is not finding SQL up and running.

    What you can do is ensure that SQL server is up and running on startup (Service is Automatic and not Automatic (delayed start))

    You can switch GFI Archiver to Automatic (delayed start) to give time for the system to boot up.

    In normal circumstances this should not occur, so not sure if you system is under heavy load during booting...

Feedback and Knowledge Base