GFI EndPointSecurity

How can we improve?

(thinking…)

Enter your idea and we'll search to see if someone has already suggested it.

If a similar idea already exists, you can support and comment on it.

If it doesn't exist, you can post your idea so others can support it.

Enter your idea and we'll search to see if someone has already suggested it.

  1. Traveler program need not require user to have local admin rights to run.

    In my POC environment, all of the PCs & Laptops in the POC network will have the GFI End Point Security installed but the rest of the corporate PCs & laptops are not install with GFI and thus required the Traveller. And that's why I cannot agreed with the requirement of the users must has local PCs or Laptops Administrators privilege before he/sh could use the traveler.

    We will not have the direction to replace my existing DLP endpoint solution with GFI just because of this requirement. Thus, I am requesting for this feature to be added into GFI and…

    1 vote
    Sign in Sign in with GFI
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Reviewed  ·  2 comments  ·  Flag idea as inappropriate…  ·  Admin →
  • Don't see your idea?

GFI EndPointSecurity

Feedback and Knowledge Base